Posts
389
Comments
117
Trackbacks
40
5.1 Sound settings fun

My old Dell Dimension 5000 has sound on the motherboard and about 4 or 5 connections coming out. I think this means it does surround sound, certainly the multitude of connections from my Speedlink Medusa Progamer headphones all have somewhere to go.

I've been wondering what has happened to the sound quality on a particular game I play - it used to sound quite good on the headphones, and the vibrate function used to come in at certain times and it all worked fine in the previous version of the game. But recently it was just coming through on the front channel as stereo - nothing on the rear, centre or subwoofer (vibrate). I changed the various settings for software and hardware sound rendering in the game.

Hunting around the web didn't shed much light, apart from the usual "outdated embedded stuff - buy a creative x-fi" but those cards are about £50. So I headed off in a different direction and established that the game uses DirectSound to talk to sound cards. So searched around on this and reminded myself of the DirectX dxdiag tool. Not sure whether I had it, I did start-run and typed in dxdiag - up came the tool. Interestingly two sound devices came up and I was reminded that my default sound device is a dsp program by SRS Labs called SRS Sandbox. This program processes music etc from 2 channels into the 5 channels that my headphones support. Normally I disable it if I'm not listening to music. It sits as the default device and processes sound through to the hardware sound card in the PC.

So I switched the default sound device to the hardware card and that was it sorted - native surround sound from the game and vibrate too. So even though sandbox was disabled, it was still confusing the game enough to make it think it only had stereo support to use.

posted on Friday, December 7, 2007 7:22 AM Print
Comments
No comments posted yet.

Post Comment

Title *
Name *
Email
Url
Comment *  
Please add 1 and 2 and type the answer here: